Vellum Web UI is Down

Incident Report for Vellum

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 20:04 UTC

Monitoring

The Vellum web app is back up and we're monitoring the situation now.
Posted Nov 28, 2025 - 19:58 UTC

Investigating

We are currently investigating why app.vellum.ai is hitting a Server Error and is unable to load.

We expect all APIs to be functioning as usual.
Posted Nov 28, 2025 - 19:56 UTC
This incident affected: Web Application.